Авторизация

Help >
Авторизация

Сразу после запуска СУБД «Библиотека» пользователь попадает на форму авторизации, где нужно ввести в текстовые поля логин и пароль, чтобы выполнить вход в систему. По щелчку по галочке с надписью «Показать пароль» можно отобразить настоящие вводимые символы пароля. Внизу расположены две кнопки: «Регистрация пользователя» и «Вход».

По нажатии на кнопку «Регистрация пользователя» появляется форма, в которой можно зарегистрировать нового пользователя. При нажатии на кнопку «Вход» происходит проверка введенных данных, и если проверка прошла успешно, то открывается рабочее место в соответствии с указанным типом пользователя.

См. также «Регистрация пользователя».

См. также «Рабочее место»

Кудинов Юрий Валерьевич © 2025.


Добавление и редактирование книги

Help >
Добавление и редактирование книги

Добавлять и редактровать книги может администратор. При нажатии на кнопку «Добавить книгу» появляется окно для ввода данных книги, в котором вводятся название книги, ее автор, год первой публикации и издания книги, ее язык, количество страниц и категорию. После нажатия на кнопку «Добавить книгу» книга добавляется в базу данных и обновлется список книг.

При нажатии на кнопку «Редактировать книгу» появляется окно для ввода данных книги, в котором вводятся данные выбранной книги. После нажатия на кнопку «Сохранить изменения» данные книги сохраняются и обновлется список книг.

При нажатии на кнопку «Удалить книгу» выводится всплывающее окно, спрашивающее у пользователя, удалить ли выбранную им на удаление книгу. Если пользователь соглашается, то книга удаляется из списка.

Кудинов Юрий Валерьевич © 2025.


Рабочее место

Help >
Рабочее место

Пользователь попадает на свое рабочее место сразу после успешной авторизации в СУБД «Библиотека».

На своем рабочем месте можно осуществить поиск книги по выбранному пользователем параметру поиска или категории книги, отсортировать книги по выбранному способ и параметру сортировки, отредактировать профиль, прочитать справку или просмотреть список выписанных книг. Строчки в таблице с названиями выписанных книг закрашиваются в желтый цвет, а если книга была выписана более 14 дней назад, то строчка с ее названием в таблице перекрашивается в красный цвет. Выписанные книги нельзя ни отредактировать, ни удалить, ни выписать.

Поиск книг осуществляется следующим образом: при вводе данных в текстовое поле для поиска в таблицу заносится книга, которую ищет пользователь по выбранным им параметрам.

Рабочее место директора

В рабочем месте директора пользователь может добавить, отредактировать или удалить книгу. Пользователь может просмотреть список книг, но и список читателей, который выводится на экран после нажатия на кнопу «Выписывания книг».

Рабочее место библиотекаря

На рабочем месте библиотекаря есть возможность просматривать и выписывать книги читателя, которому пользователь выдает книги. Выдача книг библиотекарем происходит следующим образом: пользователь выбирает книгу, нажимает на кнопку «Выписать книгу», и открывается форма с таблицей читателей, одному из которых нужно выписать книгу. Затем пользователь выбирает читателя из таблицы. В форме для выбора читателя можно выполнять поиск по выбираемому параметру: фамилии, имени или отчеству. После выбора книги и читателя выводится уведомление о выписанных книгах и обоновляется список книг на рабочем месте.

Рабочее место читателя

На рабочем месте читателя пользователь может просмотреть имеющиеся в базе данных книги и сам выписать книги. Также он может просматривать выписанные им книги и подтверждать их выписание. После подтверждения выписывания книги строчка с ее названием в таблице закрасится в зеленый цвет.

На рабочем месте пользователю предоставляется возможность изменить в любой момент изменить фамилию, имя, отчество и дату рождения. Но сперва для этого нужно нажать на кнопку «Редактирование профиля». Для сохранения изменений нужно ввести текущий пароль. Если же пользователь хочет изменить и сам пароль, то ему нужно сначала ввести его в текстовое поле для ввода нового пароля, а затем подтвердить пароль в текстовом поле для подтверждения нового пароля.

См. также «Добавление и редактирование книги».

См. также «Выдача книги».

Кудинов Юрий Валерьевич © 2025.


Регистрация пользователя

Help >
Регистрация пользователя

После нажатия на кнопку «Регистрация пользователя» в форме авторизации пользователь попадает на форму регистрации. На этой форме нужные ввести следующие данные: фамилию, имя, отчество, дату рождения, серию, номер и дату выдачи паспорта, тип пользователя (библиотекарь или клиент), логин и пароль.

Тип пользователя выбирается переключением двух кнопок с надписями «Библиотекарь» и «Клиент». Логин, вводимый пользователем при регистрации, должен быть уникальным и не существовать в системе в момент завершения регистрации. Пароли, вводимые в двух нижних текстовых полях, должны совпасть, чтобы регистрация пользователя завершилась.

Если пользователь хочет завершить завершить регистрацию, введя все необходимые данные, то он должен нажать на кнопку «Завершить регистрацию». После ввода данных и нажатия на эту кнопку появится уведомление об успешной регистрации в программе, и пользовтаель вернется на форму авторизации.

Кудинов Юрий Валерьевич © 2025.